summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-29 02:10:23 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-29 02:10:23 +0100
commit945c491a13e336fc6a42ddb85be688b1ca8b4b7b (patch)
tree21a043831599f27750f3c4dc4a42bc413ab20f12
parent5016ae374676ed5dbf594a4fde97ac5603880e4a (diff)
Quilt linearisation with .pc removal passes -f to git-rm. (Otherwise we may find that .pc/applied_patches prevents the commit.)
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a34f218..901925b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -70,6 +70,9 @@ dgit (0.23~) unstable; urgency=low
* Fix an undef reference in error message processing when quilt
fixup linearisation fails.
+ * Quilt linearisation with .pc removal passes -f to git-rm. (Otherwise
+ we may find that .pc/applied_patches prevents the commit.)
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 0d558c0..8d3addb 100755
--- a/dgit
+++ b/dgit
@@ -2478,7 +2478,7 @@ END
commit_quilty_patch();
if ($mustdeletepc) {
- runcmd @git, qw(rm -rq .pc);
+ runcmd @git, qw(rm -rqf .pc);
commit_admin "Commit removal of .pc (quilt series tracking data)";
}