summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-06-04 12:47:36 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-16 16:47:47 +0100
commitdfec10c836bfb4cf5bc80e0e90d6d7306442be1b (patch)
treecc979b6e4919f892bcacca55db73f6e4e65e1e3b
parent561bf70f8de802ba788e3d2f3be787015e5b02c0 (diff)
Split brain: Include debian/tests/control in fake dsc
Found this in a commit "WIP SPLIT BRAIN NEW DIFFS SEEM GOOD". Not sure why (I thought) it was needed. Maybe it should be reverted, but it's probably harmless.
-rwxr-xr-xdgit3
1 files changed, 2 insertions, 1 deletions
diff --git a/dgit b/dgit
index 295bbdf..c64f0fe 100755
--- a/dgit
+++ b/dgit
@@ -2942,7 +2942,8 @@ END
my @files=qw(debian/source/format debian/rules
debian/control debian/changelog);
- foreach my $maybe (qw(debian/patches debian/source/options)) {
+ foreach my $maybe (qw(debian/patches debian/source/options
+ debian/tests/control)) {
next unless stat_exists "../../../$maybe";
push @files, $maybe;
}