summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-13 20:41:33 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-13 20:41:33 +0100
commit53063f2ca0239bb803e20a2f77d58aefad2fa01d (patch)
treee8993fb14472d5d98be965579f101c18e79c728e /Makefile
parentbaa9de40ad22d98b51959054a50e46b2456d33d5 (diff)
Makefile: Provide i18n-commit target
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a0854a1..7d0c422 100644
--- a/Makefile
+++ b/Makefile
@@ -131,6 +131,11 @@ i18n i18n-update:
$(MAKE) -C po update
$(MAKE) -C po4a update
+i18n-commit:
+ set -e; x=$$(git status --porcelain); set -x; test "x$$x" = x
+ $(MAKE) i18n-update
+ git commit -a -m 'i18n-commit - autogenerated'
+
check installcheck:
clean distclean mostlyclean maintainer-clean: