summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-11-08 22:21:27 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-11-09 11:58:19 +0000
commit1b2c10f57b0257aac61a696378e9c8c05df8bf4f (patch)
treee958be79fec81a1f82679e57aebbcaf0894682d2 /Makefile
parent6fb4b888dd654e78fb263e69147de9d9df4a532b (diff)
New dgit-infrastructure binary package containing dgit-repos-server et al. Client users probably don't want this stuff. Also, it provides a convenient way to publish the dependencies.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f456d93..caac3d9 100644
--- a/Makefile
+++ b/Makefile
@@ -26,10 +26,14 @@ prefix?=/usr/local
bindir=$(prefix)/bin
mandir=$(prefix)/share/man
man1dir=$(mandir)/man1
+infraexamplesdir=$(prefix)/share/doc/dgit-infrastructure/examples
-PROGRAMS=dgit dgit-repos-server
+PROGRAMS=dgit
MAN1PAGES=dgit.1
+INFRA_PROGRAMS=dgit-repos-server dgit-ssh-dispatch
+INFRA_EXAMPLES=get-dm-txt ssh-wrap
+
all:
install: installdirs
@@ -39,6 +43,15 @@ install: installdirs
installdirs:
$(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
+install-infra: installdirs-infra
+ $(INSTALL_PROGRAM) $(addprefix infra/, $(INFRA_PROGRAMS)) \
+ $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) $(addprefix infra/, $(INFRA_EXAMPLES)) \
+ $(DESTDIR)$(infraexamplesdir)
+
+installdirs-infra:
+ $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(infraexamplesdir)
+
check installcheck:
clean distclean mostlyclean maintainer-clean: