summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-15 12:54:49 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-15 12:54:49 +0100
commitaafc50bea3ab1994044947cbc9dc26e56cd5b978 (patch)
tree91706dcb8e82cacfa2196cceeed4c23bb518b5c2 /Makefile
parenta0bbd775523d8a62188854d4f8c4514b0e1b73c9 (diff)
make it experimental
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..ed51774
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,36 @@
+# dgit
+# Integration between git and Debian-style archives
+#
+# Copyright (C)2013 Ian Jackson
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+INSTALL=install
+INSTALL_DIR=$(INSTALL) -d
+INSTALL_PROGRAM=$(INSTALL) -m 755
+prefix?=/usr/local
+
+PROGRAMS=dgit
+
+all:
+
+install: installdirs
+ $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(prefix)/bin
+
+installdirs:
+ $(INSTALL_DIR) $(DESTDIR)$(prefix)/bin
+
+check installcheck:
+
+clean distclean mostlyclean maintainer-clean: