summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-18 17:20:27 -0700
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-20 20:06:44 +0100
commite554077044924a54f12b777de972255a464ea270 (patch)
tree120d3c8634dfc77b6d03229ec8676142c3f0a5ed /Makefile
parent78e5dd0ee7b99e4904822723cdf73245b24a2d83 (diff)
Makefile: build and clean prospective *.7.pod
Build the pod section 7 manpages in "make all"; and install them, There aren't any yet, so this does nothing. Signed-off-by: Sean Whitton <spwhitton@spwhitton.name> Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6fcc9bd..27347d9 100644
--- a/Makefile
+++ b/Makefile
@@ -46,9 +46,9 @@ INFRA_PERLMODULES= \
Debian/Dgit/Infra.pm \
Debian/Dgit/Policy/Debian.pm
-all:
+all: $(MAN7PAGES)
-install: installdirs
+install: installdirs $(MAN7PAGES)
$(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
$(INSTALL_DATA) $(MAN1PAGES) $(DESTDIR)$(man1dir)
$(INSTALL_DATA) $(MAN7PAGES) $(DESTDIR)$(man7dir)
@@ -80,3 +80,11 @@ check installcheck:
clean distclean mostlyclean maintainer-clean:
rm -rf tests/tmp
+ set -e; for m in $(MAN7PAGES); do \
+ test -e $$m.pod && rm -f $$m; \
+ done
+
+%.7: %.7.pod
+ pod2man --section=7 --date="Debian Project" --center="dgit" \
+ --name=$(subst .7,,$@) \
+ $^ $@