summaryrefslogtreecommitdiff
path: root/README.git-debrebase
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-04-05 21:46:27 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 12:25:49 +0100
commit87b98b73b979494dc1625a2bf6a1ff729864a318 (patch)
tree434ea35e891c16bb34eca52eb8ede1dfbc9ea19c /README.git-debrebase
parent617ac680360b4375ee15c7895ad192a62e446e5a (diff)
git-debrebase: wip
Diffstat (limited to 'README.git-debrebase')
-rw-r--r--README.git-debrebase167
1 files changed, 82 insertions, 85 deletions
diff --git a/README.git-debrebase b/README.git-debrebase
index fc96cd8..eed1754 100644
--- a/README.git-debrebase
+++ b/README.git-debrebase
@@ -13,10 +13,10 @@ with a series of pseudomerges to make it fast-forwarding.
/ / /
1 1 1 `breakwater' branch, merging baseline
/ / / unmodified upstream code
- ---p-----p--A----p--B--C--> plus debian/ (but no debian/patches)
- / / /
- --#-----#-------#-----> upstream
-
+ ---p-----p--A----p--B--C plus debian/ (but no debian/patches)
+ / / / no ref refers to this: we
+ --#-----#-------#-----> upstream reconstruct its identity by
+ inspecting interchange branch
Key:
1,2,3 commits touching upstream files only
@@ -55,27 +55,28 @@ take (for example) B4, above, and be able to perform functions like:
* Strip pseudomerges: Rewrite the current branch so it contains no
pseudomerges, turning ...B3 into ...p-A-1-2-B3. (This should
- make a note, in your .git/ somewhere, of the latest pseudomerge to
- be deleted.)
+ make a note, in your .git/ somewhere, of the original branch
+ tip so that it can be overwritten with a pseudomerge.)
* Cleanup branch: Reorganise the current branch so that the debian/
changes come first, turning -p-A-1-2-B3 into ...p-A-B-1-2-3.
* New upstream rebase: Start rebasing onto a new upstream version,
- turning ...#...p-A-B-1-2-3 into ...#'.A-B-p'-1-2. This would be a
- wrapper around git-rebase, which prepares p' and then tries to
- rebase 1 2 onto p'. So if you ask for an interactive rebase p'
- doesn't appear in your commit list.
+ turning ...#..p-A-B-1-2-3 into (...#..p-A-B-|...#'-)p'-1-2. This
+ would be a wrapper around git-rebase, which prepares p' and then
+ tries to rebase 1 2 onto p'. So if you ask for an interactive
+ rebase p' doesn't appear in your commit list.
- Note that the rebasing of p into p' cannot fail because p' simply
+ Note that the construction of p' cannot fail because p' simply
copies debian/ from B and and everything else from #'. (Rebasing A
and B is undesirable. We want the debian/ files to be non-rebasing
so we can `git log' and get the packaging history.)
* Record pseudomerge. This is like "committing" your patch queue.
- The LH parent is taken from the previous strip pseudomerge. (We
- should probably check that this is consistent with what we see in
- debian/changelog, but that is not a sufficient check.)
+ The LH parent is taken from the previously recorded tip. (We could
+ perhaps check that this is consistent with what we see in
+ debian/changelog, but that is not a sufficient check so the
+ recorded tip check is primary.)
Maybe some of these operations should automatically edit
debian/changelog.
@@ -101,81 +102,77 @@ would get if you untarred the origs and the debian.tar.gz, and then
deleted all the patches without applying them.
+dgit import handling
+--------------------
Consider a non-dgit NMU followed by a dgit NMU:
-
-
-
- interchange --/--B3!--%--/----D*-->
- / /
- % 4
- / 3
- / 2
- / 1
- 2* &_
- / /| \
- 1 0 00 =XBC%
- /
- /
- --p--A---> breakwater
- /
- --#--------> upstream
-
-
- Key:
-
- =XBC% dgit tarball import of .debian.tar.gz containing
- Debian packaging including changes B C and patches
-
- 0 dgit tarball import of upstream tarball
-
+
+
+
+ interchange --/--B3!--%--/----D*-->
+ / /
+ % 4
+ / 3
+ / 2
+ / 1
+ 2* &_
+ / /| \
+ 1 0 00 =XBC%
+ /
+ /
+ --p--A breakwater
+ /
+ --#--------> upstream
+
+
+ Key:
+
+ =XBC% dgit tarball import of .debian.tar.gz containing
+ Debian packaging including changes B C and patches
+
+ 0 dgit tarball import of upstream tarball
00 dgit tarball import of supplementary upstream tarball
-
- &_ dgit nearly-breakwater import
-
- &' git-debrebase converted import
-
- D' git-debrebase converted debian/ changes import
-
+ &_ dgit nearly-breakwater import
+ &' git-debrebase converted import (upstream files only)
+ D' git-debrebase converted debian/ changes import
+
* ** before and after HEAD
-
-Want to transform this into:
-
- I. No new upstream version (0 + 00 eq #)
-
- --/--B3!--%--/------D*-------------/-->
- / / /
- % 4 4**
- / 3 3
- / 2 2
- / 1 1
- 2* &_ /
- / /| \ /
- 1 0 00 =XBC% /
- / /
- / /
- --p--A-----B-----------------------C--D--->
- /
- --#----------------------------------------->
-
-
- II. New upstream (0 + 00 neq #)
-
- interchange
-
- --/--B3!--%--/------E*-------------/-->
- / / /
- % 4 4**
- / 3 3
- / 2 2
- / 1 1
- 2* &_ /
- / /| \ /
- 1 0 00 =XBC% /
- / /
- / /
- --p--A-----B--------------------p--C--D--->
- / /
+
+Want to transform this into:
+
+ I. No new upstream version (0 + 00 eq #)
+
+ --/--B3!--%--/------D*-------------/-->
+ / / /
+ % 4 4**
+ / 3 3
+ / 2 2
+ / 1 1
+ 2* &_ /
+ / /| \ /
+ 1 0 00 =XBC% /
+ / /
+ / /
+ --p--A-----B-----------------------C--D
+ /
+ --#----------------------------------------->
+
+
+ II. New upstream (0 + 00 neq #)
+
+ --/--B3!--%--/------E*-------------/-->
+ / / /
+ % 4 4**
+ / 3 3
+ / 2 2
+ / 1 1
+ 2* &_ /
+ / /| \ /
+ 1 0 00 =XBC% /
+ / /
+ / /
+ --p--A-----B--------------------p--C--D
+ / /
--#----------------------- - - / - - ----->
/
&'