summaryrefslogtreecommitdiff
path: root/TODO.BRANCH
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-15 19:40:37 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-18 13:27:59 +0100
commitd9b4c302c1e04e9047b920b2bc40896479fdacb5 (patch)
tree26f37c863e879f67821e85c639f3637a86d5d91a /TODO.BRANCH
parent8dba4a073d1eddca7e15ad60d7d5c21d016e60fc (diff)
TODO.BRANCH: add some desires
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'TODO.BRANCH')
-rw-r--r--TODO.BRANCH24
1 files changed, 21 insertions, 3 deletions
diff --git a/TODO.BRANCH b/TODO.BRANCH
index ba76b16..a8377a8 100644
--- a/TODO.BRANCH
+++ b/TODO.BRANCH
@@ -2,9 +2,24 @@
- in dopush (?), we need to sort out synthetic fast forard
this should not depend entirely on quilt mode
but will always be needed if quiltmode_splitbrain
- * On push, if ff fixup mode enabled, check debian/changelog,
- and maybe make fake merge, maybe in dgit view, maybe
- elsewhere ?
+
+ On push with split brain, do synthetic fast forward if as follows:
+ - find previous push (archive version, import, whatever
+ is result of fetch into the dgit remote tracking branch)
+ - find its version number
+ - find the tag we fetched during git_fetch_us in lrfetchrefs_f
+ [*] this may need us to arrange to fetch it
+ that is, find the DEP-14 tag
+ - find the corresponding dgit tag
+ - the dgit tag should be a descendant of the DEP-14 tag
+ - what we are pushing should be a descendant of the DEP-14 tag
+ - then we can make it also a descendant of the dgit tag
+ (make it: in dgit view only, in split brain mode)
+
+ We want a --overwrite=VERSION option which 1. adjusts
+ the version used above, and 2. does the same thing in any
+ quilt mode. If no split brain it should make the psuedomerge
+ on the user's HEAD.
Want tests for
@@ -42,3 +57,6 @@ Test that, where appropriate, maint view tags are pushed to dgit git repo
* Split quilt-gbp-build-modes into one with sbuild and one without
* Add t-tstunt-parsechangelog to various tests
+
+
+Check BTS