summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-10-10 08:40:06 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-10-10 08:40:06 -0700
commitbd5ec77ecd3c3377d7473ae055b88325aef3696b (patch)
treed6281cf838da6b8c5e218a1e7615d682c1a4dc89 /debian/rules
parent11a5cbb0e28d391324948cec33b1d40499f16d3b (diff)
parentfa303f348f6fe529cafdc5b91f9a15bddefd2b56 (diff)
Merge tag 'debian/7.0' into stretch-bpo
dgit release 7.0 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Thu 04 Oct 2018 12:36:14 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index baff8f8..da482ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,10 +30,20 @@ override_dh_gencontrol:
v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
+override_dh_auto_clean:
+ dh_auto_clean
+ make -C po clean
+
globalperl=/usr/share/perl5
override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
+ make -C po install prefix=/usr DESTDIR=../debian/tmp \
+ SUPPRESS_PO_UPDATE=1 S=''
+ make -C po4a install DESTDIR=../debian/tmp S=''
+
+override_dh_missing:
+ dh_missing --fail-missing
specpkg_install_gdr: p=git-debrebase
specpkg_install_gdr: pm=GDR