summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 01:52:05 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 16:22:07 +0100
commitcec005037f5b62cb17094df53fb25c066d6a9705 (patch)
tree56fe62560698fa6e47bd0146a4f0da55cc6369cd /debian/rules
parent698dc5075b0494a8ba396e1bd0a785443b10f7ff (diff)
git-playtree-setup: Rewrite in shell and call it from Perl
We want this because git-debpush is going to want this functionality but doesn't want to include (or have a copy of) Dgit.pm. The installation arrangements are rather ugly. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk> Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 9c2afb3..4e44118 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,6 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
+ mv debian/dgit/usr/bin/git-playtree-create debian/dgit/usr/share/dgit
make -C po4a install DESTDIR=../debian/tmp S=''
override_dh_missing:
@@ -72,6 +73,8 @@ specpkg_install_%:
# # Most of the Perl modules in this package live in
# # $(specperl). The exception is Debian::Dgit::Infra, which
# # lives in $(globalperl) and adds $(specperl) to @INC.
+# # We also abuse this for git-playtree-create. In .debs, this
+# # goes in the per-.deb @INC dir. See Dgit.pm::playtree_setup.
set -ex; \
base=debian/$(p); \
mod=Debian/Dgit/$(pm).pm; \
@@ -79,6 +82,7 @@ specpkg_install_%:
dst=$${base}$(globalperl)/$${mod}; \
mkdir -p $${dst%/*}; \
mv -f $$src $$dst; \
+ install -m 755 git-playtree-create $${base}$(specperl); \
perl -i -p -e 'next unless m/###substituted###/;' \
-e 'next unless s/^# (?=unshift \@INC,)//;' \
-e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \