summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-17 15:18:55 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-17 22:42:48 +0100
commit93c90551df21fc7df60ade835e29bdbe91f65744 (patch)
tree1e496437fa19fdeeef09a4b575c4c8979e5e98ac /debian
parent0979965eaf16aa08447be9ee4ddce293d0354154 (diff)
git-debrebase: Split into its own package
* Provide and use Debian::Dgit::GDR which does the same for @INC as Debian::Dgit:Infra, only for GDR. It's not *entirely* similar as its doc comment talks about ExitStatus too. * In Makefile, split off lots of GDR_* variables and the two targets install-gdr and installdirs-gdr We take no care that only the required manpages are built for each install target; instead, they all go in MANPAGES and `all'. * Add a control file stanza. git-debrebase takes over the dependenc on libfile-fnmatch-perl. We Recommend dgit and gbp. (Even though if you're working with neither the Debian archive nor `3.0 (quilt)', you need neither.) * In rules, add specpkg_install_gdr, to run the Makefile machinery. * In the test dependencies, GDR now means to ask for git-debrebase and also git-buildpackage (for make-patches). libfile-fnmatch-perl is handled via the dependencies of git-debrebase.deb. * Add a .gitignore for the staging area in debian/ Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'debian')
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/tests/control2
3 files changed, 15 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 3180c85..224e52a 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@ Depends: perl, libwww-perl, libdpkg-perl, git-core, devscripts, dpkg-dev,
libdigest-sha-perl, dput, curl, apt,
libjson-perl, ca-certificates,
libtext-iconv-perl, libtext-glob-perl
-Recommends: ssh-client, libfile-fnmatch-perl
+Recommends: ssh-client
Suggests: sbuild
Architecture: all
Description: git interoperability with the Debian archive
@@ -26,6 +26,15 @@ Description: git interoperability with the Debian archive
.
dgit clone and dgit fetch construct git commits from uploads.
+Package: git-debrebase
+Depends: perl, git-core, libdpkg-perl, libfile-fnmatch-perl
+ ${misc:Depends}
+Recommends: dgit, git-buildpackage
+Architecture: all
+Description: rebasing git workflow tool for Debian packaging
+ git-debrebase is a tool for representing in git, and manpulating,
+ Debian packages based on upstream source code.
+
Package: dgit-infrastructure
Depends: ${misc:Depends}, perl, git-core, gpgv, chiark-utils-bin,
libjson-perl, libdigest-sha-perl, libdbd-sqlite3-perl, sqlite3,
diff --git a/debian/rules b/debian/rules
index e51f893..baff8f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,9 +32,12 @@ override_dh_gencontrol:
globalperl=/usr/share/perl5
-override_dh_auto_install: specpkg_install_infra
+override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
+specpkg_install_gdr: p=git-debrebase
+specpkg_install_gdr: pm=GDR
+
specpkg_install_infra: p=dgit-infrastructure
specpkg_install_infra: pm=Infra
diff --git a/debian/tests/control b/debian/tests/control
index ee9b7d7..a72f1b8 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -18,7 +18,7 @@ Restrictions: x-dgit-intree-only x-dgit-git-only
Tests: gdr-diverge-nmu gdr-diverge-nmu-dgit gdr-edits gdr-import-dgit gdr-newupstream-v0 gdr-subcommands gdr-viagit
Tests-Directory: tests/tests
-Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, git-buildpackage, libfile-fnmatch-perl, faketime
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, git-debrebase, git-buildpackage, faketime
Tests: gitattributes
Tests-Directory: tests/tests