summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2019-07-05 18:11:20 +0100
committerSean Whitton <spwhitton@spwhitton.name>2019-07-07 09:54:19 +0100
commitd5e73fceebd42c985264149bf1ae36ee4ebbee6e (patch)
treed5cf4b566ce73aa4f14d3a7724be59a024e7d8d4 /debian
parenteca709b776801cbd57eed32dab8b59fe8bc9a569 (diff)
git-debpush: new binary package
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
Diffstat (limited to 'debian')
-rw-r--r--debian/control13
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/tests/control2
3 files changed, 24 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index eef4dca..15c3cd4 100644
--- a/debian/control
+++ b/debian/control
@@ -37,6 +37,19 @@ Description: rebasing git workflow tool for Debian packaging
git-debrebase is a tool for representing in git, and manipulating,
Debian packages based on upstream source code.
+Package: git-debpush
+Depends: devscripts, git, gnupg, ${misc:Depends}
+Architecture: all
+Description: client script for git pushing to Debian-style archives
+ git-debpush is a script to create and push a specially formatted
+ signed git tag. The metadata in the tag indicates that the tagged
+ commit should be pushed (or "uploaded") to a Debian-style archive.
+ .
+ Tags generated by this script can be read by an intermediary service,
+ which performs any conversion that's needed (such as producing and
+ signing a .dsc and .changes), and then uploads the result to the
+ Debian-style archive on your behalf.
+
Package: dgit-infrastructure
Depends: ${misc:Depends}, perl, git-core, gpgv, chiark-utils-bin,
libjson-perl, libdigest-sha-perl, libdbd-sqlite3-perl, sqlite3,
diff --git a/debian/rules b/debian/rules
index 8beb109..ea2ceac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,9 @@ override_dh_auto_clean:
globalperl=/usr/share/perl5
-override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
+override_dh_auto_install: specpkg_install_gdp \
+ specpkg_install_gdr \
+ specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
@@ -45,6 +47,8 @@ override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
override_dh_missing:
dh_missing --fail-missing
+specpkg_install_gdp: p=git-debpush
+
specpkg_install_gdr: p=git-debrebase
specpkg_install_gdr: pm=GDR
@@ -55,6 +59,11 @@ define specpkg_install_common
make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
endef
+specpkg_install_gdp: tok=gdp
+specpkg_install_gdp: specperl=/usr/share/dgit/gdp/perl5
+specpkg_install_gdp:
+ $(specpkg_install_common)
+
specpkg_install_%: tok=$*
specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
specpkg_install_%:
diff --git a/debian/tests/control b/debian/tests/control
index b3e1b32..0732e14 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -43,7 +43,7 @@ Depends: chiark-utils-bin, faketime, git-debrebase, git-buildpackage
Tests: manpages-format
Tests-Directory: tests/tests
-Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, man-db, make, groff, git-debrebase
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, man-db, make, groff, git-debrebase, git-debpush
Tests: defdistro-mirror mirror mirror-debnewgit mirror-private
Tests-Directory: tests/tests