summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-15 12:09:01 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-15 12:09:01 +0100
commite3160d4cf8bd0488b74f6eedb3b9ad2af6cfa3bd (patch)
tree72ef4cbbdbb87d634b4345ff5f41bc05a36f1a8c /debian
dgit (0.1) experimental; urgency=low
* Initial experimental (partial) version. # imported by dgit from the archive
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control22
-rw-r--r--debian/copyright17
-rw-r--r--debian/debhelper.log5
-rwxr-xr-xdebian/rules24
6 files changed, 75 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..cc596f3
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+dgit (0.1) experimental; urgency=low
+
+ * Initial experimental (partial) version.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 Aug 2013 12:09:01 +0100
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ebda31c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+Source: dgit
+Section: devel
+Priority: optional
+Maintainer: Ian Jackson <ijackson@chiark.greenend.org.uk>
+Standards-Version: 3.9.4.0
+Build-Depends: debhelper (>= 9)
+
+Package: dgit
+Depends: perl, libwww-perl, libdpkg-perl, git-core, devscripts, dpkg-dev,
+ ${misc:Depends}
+Recommends: ssh-client
+Architecture: all
+Description: git interoperability with the Debian archive
+ dgit (with the associated infrastructure) makes it possible to
+ treat the Debian archive as a git repository.
+ .
+ dgit push constructs uploads from git commits
+ .
+ dgit clone and dgit fetch construct git commits from uploads.
+ .
+ WARNING: This program is INCOMPLETE and WRONG and should not yet
+ be used. It is being uploaded to facilitate development.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..461cbfd
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,17 @@
+dgit
+Integration between git and Debian-style archives
+
+Copyright (C)2013 Ian Jackson
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 3 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+A copy of the GNU General Public License v3 can be found in
+/usr/share/common-licenses/GPL-3.
diff --git a/debian/debhelper.log b/debian/debhelper.log
new file mode 100644
index 0000000..19f4fcf
--- /dev/null
+++ b/debian/debhelper.log
@@ -0,0 +1,5 @@
+dh_auto_configure
+dh_auto_build
+dh_auto_test
+dh_prep
+dh_installdirs
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e4a2460
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+# dgit
+# Integration between git and Debian-style archives
+#
+# Copyright (C)2013 Ian Jackson
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+export prefix=/usr
+
+%:
+ dh $@