summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 16:39:58 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-07-21 18:01:18 +0100
commit224ca6b4a472fb9bb70f455bcea6733f9c9e99bc (patch)
treecb16cffefdf59ceb174dba4bfa165554b523f5c2 /debian
parent1e947003e9b48254d349f000eaab3849511eb55e (diff)
git-playtree-setup: Rename from git-playtree-create
The name is from when I thought it would actually mkdir. But it doesn't. No overall functional change. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'debian')
-rw-r--r--debian/git-debpush.install2
-rwxr-xr-xdebian/rules6
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/git-debpush.install b/debian/git-debpush.install
index 563b42f..afba498 100644
--- a/debian/git-debpush.install
+++ b/debian/git-debpush.install
@@ -1 +1 @@
-git-playtree-create /usr/share/git-debpush
+git-playtree-setup /usr/share/git-debpush
diff --git a/debian/rules b/debian/rules
index 6ce2c3b..4d1a760 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,7 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
- mv debian/dgit/usr/bin/git-playtree-create debian/dgit/usr/share/dgit
+ mv debian/dgit/usr/bin/git-playtree-setup debian/dgit/usr/share/dgit
make -C po4a install DESTDIR=../debian/tmp S=''
override_dh_missing:
@@ -76,7 +76,7 @@ specpkg_install_%:
# # Most of the Perl modules in this package live in
# # $(specperl). The exception is Debian::Dgit::Infra, which
# # lives in $(globalperl) and adds $(specperl) to @INC.
-# # We also abuse this for git-playtree-create. In .debs, this
+# # We also abuse this for git-playtree-setup. In .debs, this
# # goes in the per-.deb @INC dir. See Dgit.pm::playtree_setup.
set -ex; \
base=debian/$(p); \
@@ -85,7 +85,7 @@ specpkg_install_%:
dst=$${base}$(globalperl)/$${mod}; \
mkdir -p $${dst%/*}; \
mv -f $$src $$dst; \
- install -m 755 git-playtree-create $${base}$(specperl); \
+ install -m 755 git-playtree-setup $${base}$(specperl); \
perl -i -p -e 'next unless m/###substituted###/;' \
-e 'next unless s/^# (?=unshift \@INC,)//;' \
-e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \