summaryrefslogtreecommitdiff
path: root/dgit-nmu-simple.7.pod
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-29 07:33:51 -0700
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-30 17:14:31 +0000
commit257cbdd6d28d62dc41650774054d2e2dd923c91a (patch)
tree68bf2fb4ad7dbf35eb369895d8f51e08d98dd686 /dgit-nmu-simple.7.pod
parent2c317e2cfb41c9cb5c9fa732e2ea4dbbda79fde7 (diff)
dgit-nmu-simple(7): Sample `dch` commands
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
Diffstat (limited to 'dgit-nmu-simple.7.pod')
-rw-r--r--dgit-nmu-simple.7.pod5
1 files changed, 3 insertions, 2 deletions
diff --git a/dgit-nmu-simple.7.pod b/dgit-nmu-simple.7.pod
index cca461b..057f1c8 100644
--- a/dgit-nmu-simple.7.pod
+++ b/dgit-nmu-simple.7.pod
@@ -39,10 +39,11 @@ consult the appropriate C<dgit-maint-*(7)> workflow tutorial,
% dgit clone glibc jessie
% cd glibc
% git am ~/glibc-security-fix.diff
- [ edit debian/changelog to introduce a ~ version, and commit it ]
+ % dch --nmu Apply upstream's fix for foo bug.
+ % git add debian/changelog && git commit -m"NMU changelog entry"
% dpkg-buildpackage -uc -b
[ run your tests ]
- [ edit debian/changelog to prepare for release, and commit it ]
+ % dch -r && git add debian/changelog && git commit -m"Finalise NMU"
% dgit -wgf sbuild -A -c jessie
[ final tests on generated .debs ]
% dgit -wgf push jessie