summaryrefslogtreecommitdiff
path: root/dgit-user.7.pod
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-08 01:06:44 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-11-08 01:06:44 +0000
commit1d50b7dfe4148df2eebd5ee36ff79b9bf65defa8 (patch)
tree936d9dc5635a371a584cfa88a0d22fba791b77fe /dgit-user.7.pod
parent1a67af8025d1b9f15f0365519ca39ae668140aec (diff)
dgit-user(7): More info about multisuite branch
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit-user.7.pod')
-rw-r--r--dgit-user.7.pod26
1 files changed, 20 insertions, 6 deletions
diff --git a/dgit-user.7.pod b/dgit-user.7.pod
index d341605..95d08d8 100644
--- a/dgit-user.7.pod
+++ b/dgit-user.7.pod
@@ -55,7 +55,7 @@ Later:
=over 4
% cd glibc
- % dgit pull jessie
+ % dgit pull jessie,-security
% gbp dch -S --since=dgit/dgit/sid --ignore-branch --commit
% dpkg-buildpackage -uc -b
% sudo dpkg -i ../libc6_*.deb
@@ -66,7 +66,7 @@ Later:
=over 4
- % dgit clone glibc jessie
+ % dgit clone glibc jessie,-security
% cd glibc
=back
@@ -125,15 +125,22 @@ If you don't know what you're running, try this:
=back
+For Debian, you should add C<,-security>
+to the end of the suite name.
+Hence, in our example
+C<jessie> becomes C<jessie,-security>.
+(Yes, with a comma.)
+
=head1 WHAT DGIT CLONE PRODUCES
=head2 What branches are there
dgit clone will give you a new working tree,
-and arrange for you to be on a branch like
-C<dgit/jessie>.
+and arrange for you to be on a branch named like
+C<dgit/jessie,-security> (yes, with a comma in the branch name).
-There is a tracking branch for the contents of the archive, called
+For each release (like C<jessie>)
+there is a tracking branch for the contents of the archive, called
C<remotes/dgit/dgit/jessie>
(and similarly for other suites). This can be updated with
C<dgit fetch jessie>.
@@ -141,6 +148,10 @@ This, the I<remote suite branch>,
is synthesized by your local copy of dgit.
It is fast forwarding.
+Debian separates out the security updates, into C<debian-security>.
+Telling dgit C<debian,-security> means that it should include
+any updates available in C<debian-security>.
+
(You can also dgit fetch in a tree that wasn't made by dgit clone.
If there's no C<debian/changelog>
you'll have to supply a C<-p>I<package> option to dgit fetch.)
@@ -189,6 +200,9 @@ history invented by dgit.
dgit histories often contain automatically-generated commits,
including commits which make no changes but just serve
to make a rebasing branch fast-forward.
+This is particularly true of
+combining branches like
+C<jessie,-security>.
If the package maintainer is using git then
after dgit clone
@@ -362,7 +376,7 @@ but passing C<--force-overwrite> to dpkg will help
=head1 SHARING YOUR WORK
-The C<dgit/jessie> branch (or whatever) is a normal git branch.
+The C<dgit/jessie,-security> branch (or whatever) is a normal git branch.
You can use C<git push> to publish it on any suitable git server.
Anyone who gets that git branch from you