summaryrefslogtreecommitdiff
path: root/dgit.1
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-27 18:22:35 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-27 18:24:59 +0100
commit99b7b3246b32cde43dca421571c06f42e00c1baf (patch)
treec2afedf10f09491c8234f98b079bac40f59f3abf /dgit.1
parentb90682a618eb7aa2405517759c2d978c8b89c4f9 (diff)
dgit(1): Better description of --overwrite.
In particular, be clear that --overwrite (without previous-version) is quite a weak promise: that the version you are uploading contains everything in your changelog. It won't overwrite willy-nilly. Somewhat apropos of discussion in #902534. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit.1')
-rw-r--r--dgit.122
1 files changed, 15 insertions, 7 deletions
diff --git a/dgit.1 b/dgit.1
index f15fecf..cbf0cde 100644
--- a/dgit.1
+++ b/dgit.1
@@ -514,11 +514,15 @@ push will still ensure that the .dsc you upload and the git tree
you push are identical, so this option won't make broken pushes.)
.TP
.BR --overwrite [=\fIprevious-version\fR]
-Declare that even though your git branch may not be a descendant
+Declare that your HEAD really does contain
+all the (wanted) changes
+from all versions listed in its changelog;
+or, all (wanted) changes from
+.IR previous-version .
+This promise is needed when
+your git branch is not a descendant
of the version in the archive
-according to the revision history,
-it really does contain
-all the (wanted) changes from that version.
+according to the git revision history.
This option is useful if you are the maintainer, and you have
incorporated NMU changes into your own git workflow in a way that
@@ -530,15 +534,19 @@ to a particular suite.
See
.BR dgit-maint- \fI*\fR (7) .
-.I previous-version
-ought to be the version currently in the archive. If
+If
.I previous-version
is not
specified, dgit will check that the version in the archive is
mentioned in your debian/changelog.
(This will avoid losing
-changes unless someone committed to git a finalised changelog
+changes, even with
+.BR --overwrite ,
+unless someone committed to git a finalised changelog
entry, and then made later changes to that version.)
+If
+.IR previous-version
+is specified, it ought to be the version currently in the archive.
dgit push --overwrite
will, if necessary, make a