summaryrefslogtreecommitdiff
path: root/dgit.1
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-02-04 16:30:13 -0700
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-01-07 19:31:59 +0000
commit16ccc5dda376696f4cb37639017dc13e70ca9324 (patch)
tree83d9c17ebdacd7f11098215dedb2bc402a7b0e2a /dgit.1
parent58c8f2001ffd3e7525c719d2b11197d96cf23785 (diff)
dgit: New command: push-source
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name> Acked-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit.1')
-rw-r--r--dgit.110
1 files changed, 9 insertions, 1 deletions
diff --git a/dgit.1 b/dgit.1
index 1bf4a2c..047695b 100644
--- a/dgit.1
+++ b/dgit.1
@@ -17,7 +17,7 @@ dgit \- git integration with the Debian archive
[\fIbuild\-opts\fp]
.br
.B dgit
-[\fIdgit\-opts\fP] \fBpush\fP [\fIdgit\-opts\fP]
+[\fIdgit\-opts\fP] \fBpush\fP|\fBpush-source\fP [\fIdgit\-opts\fP]
[\fIsuite\fP]
.br
.B dgit
@@ -185,6 +185,14 @@ dgit push always uses the package, suite and version specified in the
debian/changelog and the .dsc, which must agree. If the command line
specifies a suite then that must match too.
.TP
+\fBdgit push-source\fR [\fIsuite\fP]
+Without \fB-C\fR, builds a source package and dgit pushes it. Saying
+\fBdgit push-source\fR is like saying "update the source code in the
+archive to match my git HEAD, and let the autobuilders do the rest."
+
+With \fB-C\fR, performs a dgit push, additionally ensuring that no
+binary packages are uploaded.
+.TP
\fBdgit rpush\fR \fIbuild-host\fR\fB:\fR\fIbuild-dir\fR [\fIpush args...\fR]
Pushes the contents of the specified directory on a remote machine.
This is like running dgit push on build-host with build-dir as the