summaryrefslogtreecommitdiff
path: root/dgit.1
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-17 13:29:03 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-17 13:29:03 +0100
commit1ea98cbf5d01ea6110b2c95b4be941fcfce787a6 (patch)
treee2c2500aed4ed491579704888cff58975f711d38 /dgit.1
parentedc1cd049cfa01e7d6249ea199725d2448858704 (diff)
documentation: Discuss gdr make-patches vs dgit quilt-fixup, etc.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit.1')
-rw-r--r--dgit.120
1 files changed, 17 insertions, 3 deletions
diff --git a/dgit.1 b/dgit.1
index 2705d62..4cbf10f 100644
--- a/dgit.1
+++ b/dgit.1
@@ -185,14 +185,19 @@ archive.
dgit push always uses the package, suite and version specified in the
debian/changelog and the .dsc, which must agree. If the command line
specifies a suite then that must match too.
+
+With \fB-C\fR, performs a dgit push, additionally ensuring that no
+binary packages are uploaded.
+
+When used on a git-debrebase branch,
+dgit calls git-debrebase
+to prepare the branch
+for source package upload and push.
.TP
\fBdgit push-source\fR [\fIsuite\fP]
Without \fB-C\fR, builds a source package and dgit pushes it. Saying
\fBdgit push-source\fR is like saying "update the source code in the
archive to match my git HEAD, and let the autobuilders do the rest."
-
-With \fB-C\fR, performs a dgit push, additionally ensuring that no
-binary packages are uploaded.
.TP
\fBdgit rpush\fR \fIbuild-host\fR\fB:\fR\fIbuild-dir\fR [\fIpush args...\fR]
Pushes the contents of the specified directory on a remote machine.
@@ -286,6 +291,15 @@ new quilt patch. dgit cannot convert nontrivial merges, or certain
other kinds of more exotic history. If dgit can't find a suitable
linearisation of your history, by default it will fail, but you can
ask it to generate a single squashed patch instead.
+
+When used with a git-debrebase branch,
+dgit will ask git-debrebase to prepare patches.
+However,
+dgit can make patches in some situations where git-debrebase fails,
+so dgit quilt-fixup can be useful in its own right.
+To always use dgit's own patch generator
+instead of git-debrebase make-patches,
+pass --git-debrebase=true to dgit.
.TP
\fBdgit import-dsc\fR [\fIsub-options\fR] \fI../path/to/.dsc\fR [\fB+\fR|\fB..\fR]branch
Import a Debian-format source package,