summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-08 12:01:36 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-08 22:14:48 +0000
commit194f799def5d74fba6f7e035372b2f4e01aa6ec7 (patch)
treee5bb74911ab3c3260bcfabc6131686401edebb4e /dgit
parentb1efb14b9990ecee625335bafd206635ff2ec245 (diff)
dgit: Option parsing: Move notpushing call in fetch/pull
We should use the calculated $idistro and $isuite Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit2
1 files changed, 1 insertions, 1 deletions
diff --git a/dgit b/dgit
index e90baf3..0ae84b2 100755
--- a/dgit
+++ b/dgit
@@ -4131,7 +4131,6 @@ sub branchsuite () {
}
sub fetchpullargs () {
- notpushing();
if (!defined $package) {
my $sourcep = parsecontrol('debian/control','debian/control');
$package = getfield $sourcep, 'Source';
@@ -4147,6 +4146,7 @@ sub fetchpullargs () {
} else {
badusage "incorrect arguments to dgit fetch or dgit pull";
}
+ notpushing();
}
sub cmd_fetch {