summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2019-06-15 16:13:14 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2019-06-28 12:45:38 +0100
commit9e33aefbc2d0b2cebdadba42bdf170ff608b5ac9 (patch)
tree64d38651820c613c4b087187177dbd8f4ccf8430 /dgit
parentd7a62f56ca2269cd39b255f8397fd68adc4a16f0 (diff)
dgit: When propagating pseudomerge error, strip leading \n
fail adds an initial \n to provide a blank line separating the error message from previous output. We want to strip any such thing away again. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit3
1 files changed, 2 insertions, 1 deletions
diff --git a/dgit b/dgit
index 769e48e..f0a1e76 100755
--- a/dgit
+++ b/dgit
@@ -4134,6 +4134,7 @@ sub pseudomerge_version_check ($$) {
$cd = $gf->('Distribution');
};
if ($@) {
+ $@ =~ s/^\n//s;
$@ =~ s/^dgit: //gm;
fail "$@".
f_ "Perhaps debian/changelog does not mention %s ?", $v;
@@ -6786,7 +6787,7 @@ sub build_source {
unlink "$buildproductsdir/$sourcechanges" or $!==ENOENT
or fail f_ "remove %s: %s", $sourcechanges, $!;
}
- confess unless !!$made_split_brain == !!$do_split_brain;
+# confess unless !!$made_split_brain == !!$do_split_brain;
my @cmd = (@dpkgsource, qw(-b --));
my $leafdir;