summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-17 17:02:33 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-17 17:02:33 +0100
commitc49ed487a8eba41e990e483dc1851c817ed5237a (patch)
treedf2cbbb1b44059a6417f8cc2e77c5863a09a5a42 /dgit
parent253d72055689c3dafcb32c2090ae1739a02a3105 (diff)
clean things
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit5
1 files changed, 4 insertions, 1 deletions
diff --git a/dgit b/dgit
index b185124..f724369 100755
--- a/dgit
+++ b/dgit
@@ -42,6 +42,7 @@ our (@git) = qw(git);
our (@dget) = qw(dget);
our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
+our (@cleancmd) = qw(debian/rules clean);
our $keyid;
our $debug = 0;
@@ -584,7 +585,7 @@ sub commit_quilty_patch () {
sub dopush () {
print DEBUG "actually entering push\n";
- runcmd qw(debian/rules clean);
+ runcmd @cleancmd;
my $clogp = parsechangelog();
$package = $clogp->{Source};
my $dscfn = "${package}_$clogp->{Version}.dsc";
@@ -761,6 +762,8 @@ sub parseopts () {
push @$om, $2;
} elsif (m/^--existing-package=(.*)/s) {
$existing_package = $1;
+ } elsif (m/^--clean-command=(.*)/s) {
+ @cleancmd = split /\s+/, $1;
} else {
die "$_ ?";
}