summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-06-04 11:36:22 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-16 16:47:46 +0100
commit30dfa155fe762380e2188a4e4c18e6beb5ea713e (patch)
treefad351f9a09e34c56e983886c82a14155c5f7fce /dgit
parent93022741720ca0f2fe56b3d8803a515147e5c5f7 (diff)
Split brain: Fake .dsc contains d/control and d/changelog too
We will want these because we're going to be doing more exciting dpkg-source and gbp operations etc.
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit3
1 files changed, 2 insertions, 1 deletions
diff --git a/dgit b/dgit
index 97d8bce..299c531 100755
--- a/dgit
+++ b/dgit
@@ -2919,7 +2919,8 @@ END
quilt_fixup_linkorigs($upstreamversion, $dscaddfile);
- my @files=qw(debian/source/format debian/rules);
+ my @files=qw(debian/source/format debian/rules
+ debian/control debian/changelog);
foreach my $maybe (qw(debian/patches debian/source/options)) {
next unless stat_exists "../../../$maybe";
push @files, $maybe;