summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-09 01:07:59 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-10 01:01:10 +0100
commit53e604f8698a5332bbf2764b971c06295c104cd1 (patch)
treee2e0e8f87764facc3f18d5fffc7a177f27239575 /dgit
parent47058aec784f7f3fba920567d634eb61c0a24712 (diff)
Quilt output: Include Date header
Copy this from the commit's author date. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit4
1 files changed, 4 insertions, 0 deletions
diff --git a/dgit b/dgit
index 836e19d..2acf849 100755
--- a/dgit
+++ b/dgit
@@ -3973,6 +3973,9 @@ sub quiltify ($$$$) {
$commitdata =~ m/^author (.*) \d+ [-+0-9]+$/m or die "$cc ?";
my $author = $1;
+ my $commitdate = cmdoutput
+ @git, qw(log -n1 --pretty=format:%aD), $cc;
+
$msg =~ s/^(.*)\n*/$1\n/ or die "$cc $msg ?";
my $title = $1;
@@ -3999,6 +4002,7 @@ sub quiltify ($$$$) {
runcmd @git, qw(checkout -q), $target, qw(debian/changelog);
quiltify_dpkg_commit "$patchname$index", $author, $msg,
+ "Date: $commitdate\n".
"X-Dgit-Generated: $clogp->{Version} $cc\n";
runcmd @git, qw(checkout -q), $cc, qw(debian/changelog);