summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-18 13:26:01 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-25 20:12:52 +0100
commiteefe676b1f2bb245710f17e7b7694b420d0a00db (patch)
tree20c0197b309fd22d1a7afadc3348da8b2cc217e4 /dgit
parent4ce800ddb6a9f36b35e2a468af7d20e9604d2601 (diff)
Changelog handling: Replace a call to parsechangelog with commit_getclogp
This is less code, and takes advantage of the memoisation. No overall functional change. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit5
1 files changed, 1 insertions, 4 deletions
diff --git a/dgit b/dgit
index e125922..13d17ea 100755
--- a/dgit
+++ b/dgit
@@ -2127,10 +2127,7 @@ END
if (defined $skew_warning_vsn) {
mkpath '.git/dgit';
printdebug "SKEW CHECK WANT $skew_warning_vsn\n";
- my $clogf = ".git/dgit/changelog.tmp";
- runcmd shell_cmd "exec >$clogf",
- @git, qw(cat-file blob), "$hash:debian/changelog";
- my $gotclogp = parsechangelog("-l$clogf");
+ my $gotclogp = commit_getclogp($hash);
my $got_vsn = getfield $gotclogp, 'Version';
printdebug "SKEW CHECK GOT $got_vsn\n";
if (version_compare($got_vsn, $skew_warning_vsn) < 0) {