summaryrefslogtreecommitdiff
path: root/po4a/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-11-17 11:00:54 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-11-17 11:00:54 -0700
commitfde00691054302b53783d14880ef015e8f81758b (patch)
tree323aae3f069791b9b9966ffdbf8fe3f5fc979cd6 /po4a/Makefile
parent43faee259ac0418b98f0c973a794c21f47c9d1c1 (diff)
parentbfb113c41cdc9bc875cec6f1c24f930e664e853e (diff)
Merge tag 'debian/8.1' into stretch-bpo
dgit release 8.1 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Wed 07 Nov 2018 07:11:36 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'po4a/Makefile')
-rw-r--r--po4a/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/po4a/Makefile b/po4a/Makefile
index c759ce8..e88aded 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -75,6 +75,11 @@
# tree.
#
# make targets: install
+#
+# Check:
+#
+# make targets: check
+# pairwise-pocheck.check
default: pofiles
@@ -84,6 +89,8 @@ PO4A ?= po4a
all update: translated
+check: po4a.cfg.check pairwise-pocheck.check
+
pofiles: po4a.cfg
$(PO4A) --no-translations $<
@@ -97,10 +104,13 @@ po4a.cfg.check: list-documents
./$< >$@.tmp
diff po4a.cfg $@.tmp
+pairwise-pocheck.check:
+ ./pairwise-pocheck
+
t = ../.po4a.translated-only
p = ../po4a
-translated-only: po4a.cfg
+translated-only: po4a.cfg pairwise-pocheck.check
rm -rf $t && mkdir $t
cd $t && ln -s $p/*.po $p/*.pot $p/po4a.cfg .
cd $t && $(PO4A) po4a.cfg
@@ -114,7 +124,11 @@ translated-only: po4a.cfg
.PRECIOUS: .po4a.%.cfg
-preview.%: .po4a.%.cfg
+pairwise-pocheck.%.check:
+ @tclsh /dev/null || printf ':;:; Please run apt-get install tcl\n'
+ ./pairwise-pocheck $*
+
+preview.%: .po4a.%.cfg pairwise-pocheck.%.check
$S $(PO4A) $<
$S ./install-documents >/dev/null .$*.translated $@
@ echo '# runes to preview the various final tranlated manpages:'