summaryrefslogtreecommitdiff
path: root/po4a/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-04 01:14:19 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-04 02:02:19 +0100
commitbddc9e6b3cc520514c013509520422d6cb482e53 (patch)
tree66bf24479bb7f33d7878ab011ef523ce10793b42 /po4a/Makefile
parent73ecf6019fa28d7464af55cb023600f5c389623e (diff)
po4a: Makefile: Honour PO4A and use i18n-common.make
No functional change unless PO4A is in the environment. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'po4a/Makefile')
-rw-r--r--po4a/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/po4a/Makefile b/po4a/Makefile
index 3a3310d..6cb887c 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -79,20 +79,16 @@
default: pofiles
+include ../i18n-common.make
+PO4A ?= po4a
+
all: translated-always
pofiles: po4a.cfg
- po4a --no-translations $<
-
-e=set -e; exec >$@.tmp
-f=mv -f $@.tmp $@
-o= >$@.tmp && $f
-
-S=@
-# Set S='' to see commands being run
+ $(PO4A) --no-translations $<
translated: po4a.cfg
- po4a $<
+ $(PO4A) $<
po4a.cfg: list-documents
./$< $o
@@ -107,7 +103,7 @@ p = ../po4a
translated-only: po4a.cfg
rm -rf $t && mkdir $t
cd $t && ln -s $p/*.po $p/*.pot $p/po4a.cfg .
- cd $t && po4a po4a.cfg
+ cd $t && $(PO4A) po4a.cfg
! test -d $t/translated || \
cp -al --remove-destination $t/translated .
@@ -119,7 +115,7 @@ translated-only: po4a.cfg
.PRECIOUS: .po4a.%.cfg
preview.%: .po4a.%.cfg
- $S po4a $<
+ $S $(PO4A) $<
$S ./install-documents >/dev/null .$*.translated $@
@ echo '# runes to preview the various final tranlated manpages:'
$S find $@ -type f -printf 'man -l %p\n'