summaryrefslogtreecommitdiff
path: root/po4a/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-11-07 22:33:06 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-11-07 23:08:30 +0000
commitdf90a0804dbbbc8be02fcf86cdda6a47e9a16c64 (patch)
tree5f15c337a12c55423d396516b75c067e97d24312 /po4a/Makefile
parent67b3cfa92470948c95a0fb9a949eeaa48a47d42a (diff)
po4a: pairwise-pocheck: Provide make targets to invoke it explicitly
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'po4a/Makefile')
-rw-r--r--po4a/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/po4a/Makefile b/po4a/Makefile
index c759ce8..3354812 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -75,6 +75,11 @@
# tree.
#
# make targets: install
+#
+# Check:
+#
+# make targets: check
+# pairwise-pocheck.check
default: pofiles
@@ -84,6 +89,8 @@ PO4A ?= po4a
all update: translated
+check: po4a.cfg.check pairwise-pocheck.check
+
pofiles: po4a.cfg
$(PO4A) --no-translations $<
@@ -97,6 +104,9 @@ po4a.cfg.check: list-documents
./$< >$@.tmp
diff po4a.cfg $@.tmp
+pairwise-pocheck.check:
+ ./pairwise-pocheck
+
t = ../.po4a.translated-only
p = ../po4a
@@ -114,6 +124,9 @@ translated-only: po4a.cfg
.PRECIOUS: .po4a.%.cfg
+pairwise-pocheck.%.check:
+ ./pairwise-pocheck $*
+
preview.%: .po4a.%.cfg
$S $(PO4A) $<
$S ./install-documents >/dev/null .$*.translated $@