summaryrefslogtreecommitdiff
path: root/po4a/install-documents
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-10-10 08:40:06 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-10-10 08:40:06 -0700
commitbd5ec77ecd3c3377d7473ae055b88325aef3696b (patch)
treed6281cf838da6b8c5e218a1e7615d682c1a4dc89 /po4a/install-documents
parent11a5cbb0e28d391324948cec33b1d40499f16d3b (diff)
parentfa303f348f6fe529cafdc5b91f9a15bddefd2b56 (diff)
Merge tag 'debian/7.0' into stretch-bpo
dgit release 7.0 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Thu 04 Oct 2018 12:36:14 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'po4a/install-documents')
-rwxr-xr-xpo4a/install-documents27
1 files changed, 27 insertions, 0 deletions
diff --git a/po4a/install-documents b/po4a/install-documents
new file mode 100755
index 0000000..138c88e
--- /dev/null
+++ b/po4a/install-documents
@@ -0,0 +1,27 @@
+#!/bin/bash
+set -e
+
+srcdir=$1; shift
+destdir=$1; shift
+
+mkdir -p "$srcdir"
+
+docs=( $( ( cd "$srcdir" && find man -type f ) | sed 's#\.pod$##' ) )
+
+echo ${docs[*]}
+
+x () {
+ echo "+ $*";
+ "$@"
+}
+
+if [ "${#docs}" = 0 ]; then exit 0; fi
+
+x ${MAKE-make} -s -C "$srcdir" -f ../../Makefile ${docs[@]}
+
+mandest=$destdir/usr/share
+
+for f in "${docs[@]}"; do
+ mkdir -p "$mandest/${f%/*}"
+ x cp "$srcdir/$f" "$mandest/$f"
+done