summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
commitcc704da52293859135140d783697360b55ea34a5 (patch)
tree7ca5bdb2177cb05a798d4ac8d292057a2c3abcf1 /tests/Makefile
parent29176533eff12cd3e90e3a3ce60e59ec1077b2ac (diff)
parent80660b109ae671e5164c6738919f34db06719236 (diff)
Merge tag 'debian/6.11' into stretch-bpo
dgit release 6.11 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sun 26 Aug 2018 01:58:34 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 88bc0a0..31eb7b6 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -11,11 +11,11 @@ all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
tests/tmp/%.ok: tests/tests/%
ifeq ($(DGIT_TEST_RETRY_COUNT),)
- tests/tests/$* >tests/tmp/$*.log 2>&1
+ $(DGIT_TEST_RUN_PFX) tests/tests/$* >tests/tmp/$*.log 2>&1
else
@for retry in $$( seq 1 $(DGIT_TEST_RETRY_COUNT) ); do \
echo "[$$retry] $*"; \
- tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
+ $(DGIT_TEST_RUN_PFX) tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
rc=$$?; \
if [ $$rc = 0 ]; then exit 0; fi; \
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \