summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-03-22 17:59:08 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-03-22 17:59:08 +0000
commit742e4ad0fb818f41aeef52aad862e120b9a5d5af (patch)
treedaa2654861811bf9dd0b1cea79d3442340141454 /tests/Makefile
parentd5013886bfac8d8997d1e4ec8fd32f1a0a6e62d1 (diff)
Test suite: Use make for parallel execution
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
new file mode 100644
index 0000000..011bd3c
--- /dev/null
+++ b/tests/Makefile
@@ -0,0 +1,14 @@
+# usage: tests/using-intree make -f tests/Makefile
+# (optionally setting TESTSCRIPTS='tests/tests/foo tests/tests/bar')
+
+TESTSCRIPTS ?= $(shell run-parts --list tests/tests)
+TESTNAMES := $(notdir $(TESTSCRIPTS))
+
+all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
+ @echo "ALL PASSED"
+
+tests/tmp:
+ mkdir -p $@
+
+tests/tmp/%.ok: tests/tmp
+ tests/tests/$* >tests/tmp/$*.log 2>&1