summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 17:36:18 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 18:32:29 +0100
commitada48ca013e77d7e821d326db40bc1a59ba639ea (patch)
tree795d0bcac6795fcf7168e1e60a88186ddba383f4 /tests/Makefile
parent417bcf4ea06b9e181c39734e121d9a32cf7cbb21 (diff)
Test suite: Introduce tests/list-tests
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 011bd3c..157b487 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -1,7 +1,7 @@
# usage: tests/using-intree make -f tests/Makefile
# (optionally setting TESTSCRIPTS='tests/tests/foo tests/tests/bar')
-TESTSCRIPTS ?= $(shell run-parts --list tests/tests)
+TESTSCRIPTS ?= $(shell tests/list-tests)
TESTNAMES := $(notdir $(TESTSCRIPTS))
all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)