summaryrefslogtreecommitdiff
path: root/tests/lib-import-chk
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-02-05 19:45:11 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-02-05 20:36:49 +0000
commit8c0703a043f1deedc4dee9500d8f7da8b382543a (patch)
tree9f569512c5f0a8f2fb0dfa2eaa748a966c13cc8b /tests/lib-import-chk
parent17cbb0b93e661fa2f163b155fd4505b0e4b70647 (diff)
test suite: lib-import-chk: Test commit authorship
Check that commits have smae authorship as appears in the changelog. (Or, at least, the same authorship set.) Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib-import-chk')
-rw-r--r--tests/lib-import-chk12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/lib-import-chk b/tests/lib-import-chk
index ee33cbe..a456b01 100644
--- a/tests/lib-import-chk
+++ b/tests/lib-import-chk
@@ -1,4 +1,14 @@
+t-import-chk-authorship () {
+ perl -ne 'print $1,"\n" if m/^ -- (\S.*\>) /' debian/changelog \
+ | sort -u \
+ > $tmp/authorship.changelog
+ git log --pretty=format:'%an <%ae>%n%cn <%ce>' \
+ | sort -u \
+ > $tmp/authorship.commits
+ diff $tmp/authorship.{changelog,commits}
+}
+
t-import-chk1 () {
p=$1
v=$2
@@ -15,6 +25,8 @@ t-import-chk2() {
cd $p
+ t-import-chk-authorship
+
git branch first-import
m='Commit for import check'