summaryrefslogtreecommitdiff
path: root/tests/lib-import-chk
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 00:15:44 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 00:15:48 +0100
commit61f92b326da0efea1cf4d3c263ef0e0b7cacfc25 (patch)
treef186a790a765a894c20ec0f2bae9126df067dac1 /tests/lib-import-chk
parent80489b3ec6643c06d525ec39a7d72135286ba62c (diff)
test suite: Always pass LC_COLLATE=C to sort(1).
Specifically, by replacing every invocation of sort with the new function t-sort. The one case where we already took care of this, we change LC_ALL to LC_COLLATE, which should be sufficient. Closes:#903006. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib-import-chk')
-rw-r--r--tests/lib-import-chk8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/lib-import-chk b/tests/lib-import-chk
index 88984c1..d6633f9 100644
--- a/tests/lib-import-chk
+++ b/tests/lib-import-chk
@@ -1,11 +1,11 @@
t-import-chk-authorship () {
perl -ne 'print $1,"\n" if m/^ -- (\S.*\>) /' debian/changelog \
- | sort -u \
+ | t-sort -u \
> $tmp/authorship.changelog
${import_chk_changelog_massage:-:} $tmp/authorship.changelog
git log --pretty=format:'%an <%ae>%n%cn <%ce>' \
- | sort -u \
+ | t-sort -u \
> $tmp/authorship.commits
diff $tmp/authorship.{changelog,commits}
}
@@ -63,7 +63,7 @@ t-import-chk2() {
t-ref-same refs/heads/first-2nd-import
for orig in ../${p}_${v%-*}.orig*.tar.*; do
- tar -atf $orig | LC_ALL=C sort >../files.o
+ tar -atf $orig | t-sort >../files.o
pfx=$(perl <../files.o -ne '
while (<>) {
m#^([^/]+/)# or exit 0;
@@ -87,7 +87,7 @@ t-import-chk2() {
t-ref-same-val "$orig $start" "$imp"
done
git ls-tree -r --name-only "$t_ref_val:" \
- | sort >../files.g
+ | t-sort >../files.g
diff ../files.{o,g}
done
cd ..