summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-02-17 19:23:58 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 16:04:33 +0100
commite26989680f3c7f3f219e799c3a64f1e4ee3808ee (patch)
treefcf0a033dc963498acd567b3e5f9efea2a3152ab /tests/lib
parent5b79751a25c556b457c0c429041bee2219d552f0 (diff)
git-debrebase: test suite: gdr-*: use faketime to control dch dates
This means that the dgit- and gdr-generated commits with dates from changelogs are all adjusted. This makes the gitk in the gdr tests look more like a real one would, so we can see if it's pretty. (It also makes it easier to debug the tests.) Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/lib b/tests/lib
index 6533a90..8722522 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1005,7 +1005,7 @@ t-commit () {
}
t-dch-commit () {
- dch "$@"
+ faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
git commit -m "dch $*" debian/changelog
}