summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-12 12:37:45 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-12 13:43:08 +0100
commita47f1af332372a372bf5758d1e3d9eeffe14acbd (patch)
treee3c4a66726c944a2c1f977bde9714f3d8b48062f /tests/lib
parent6a552157942a5b23579655f44f9b23a88041f53e (diff)
test suite: Factor out t-dch-commit-r
The pattern `dch -r sid' is actually wrong and we will want to change it. See #903441 and #903598. For future-proofing, factor this out before we fix it. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/lib b/tests/lib
index 4ef275c..04d1f2d 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1006,6 +1006,16 @@ t-commit () {
revision=$(( ${revision-0} + 1 ))
}
+t-dch-r-rune () {
+ local cmd="$1"; shift
+ local suite=${1-unstable}
+ $cmd -r sid
+}
+
+t-dch-commit-r () {
+ t-dch-r-rune t-dch-commit "$@"
+}
+
t-dch-commit () {
faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
git commit -m "dch $*" debian/changelog