summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-08-05 20:37:32 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-05 13:41:48 +0100
commit9243bf289e6ece2b20765a6cd850aab4c66f98e8 (patch)
treece77c090c3f45158a37b3fa765e3cced5e9b63c2 /tests/lib
parent9588a8e67017c5e859e6da5b5a0271712be78fad (diff)
Test suite: t-commit: Permit specification of the suite in $3
This also means that we need to default $2 with ${2:-} since callers want need to pass an empty value for the version, to get the default. No functional change since none of the call sites use this yet. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/lib b/tests/lib
index 914509b..cebe10d 100644
--- a/tests/lib
+++ b/tests/lib
@@ -593,8 +593,8 @@ t-gbp-example-prep () {
t-commit () {
local msg=$1
- v=${2-1.$revision}
- dch -v$v --distribution unstable "$1"
+ v=${2:-1.$revision}
+ dch -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
revision=$(( ${revision-0} + 1 ))