summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-13 18:08:24 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-06-13 18:08:24 +0100
commit6206349cffcc47da7d927aeec058e579654d2075 (patch)
tree8678591b8e86de8dffdc4587d163d9f0c036d112 /tests/lib
parent0fa7c72bc9664d8ebc2e8eb4d3a2bafc03eb2f6d (diff)
Test suite: Provide t-prep-mergechangelogs and use it in debpolicy-newreject
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/lib b/tests/lib
index 5b93d98..e1bc6d9 100644
--- a/tests/lib
+++ b/tests/lib
@@ -423,6 +423,15 @@ t-tstunt-parsechangelog () {
t-tstunt dpkg-parsechangelog Dpkg/Changelog/Parse.pm
}
+t-prep-mergechangelogs () {
+ local b=merge.dpkg-mergechangelogs
+ git config $b.name 'debian/changelog merge driver'
+ git config $b.driver 'dpkg-mergechangelogs -m %O %A %B %A'
+ mkdir -p .git/info
+ echo >>.git/info/attributes \
+ 'debian/changelog merge=dpkg-mergechangelogs'
+}
+
t-ref-dsc-dgit () {
local dsc=${p}_${v}.dsc
local val=`t-822-field $tmp/incoming/$dsc Dgit`