summaryrefslogtreecommitdiff
path: root/tests/lib
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-25 17:21:37 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-26 01:20:44 +0100
commite079e1ff7f807be20888cd4cf8ca527f3e7ab6a0 (patch)
tree377a13f60d139d604703a04571d1be692e7363b4 /tests/lib
parent35c89cd28f7089073a4f9aafc1b60d8bdc3aca8a (diff)
test suite: dch: Always use tstunt/debchange
We are going to make this more sophisticated, so use it everywhere to avoid duplication. We need to soup up tstunt/debchange so that it does not depend on DGIT_TEST_REAL_DEBCHANGE. If it hasn't been put on the PATH by t-tstunt, that isn't set, and we can just run debchange from PATH. This makes faketime a test dependency for all the tests which don't have NO-DEFAULT. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/lib')
-rw-r--r--tests/lib5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/lib b/tests/lib
index 24ccf7e..376585c 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1041,7 +1041,8 @@ t-merge-conflicted-stripping-conflict-markers () {
t-commit () {
local msg=$1
v=${2:-${majorv:-1}.$revision}
- dch --force-distribution -v$v --distribution ${3:-unstable} "$1"
+ $troot/tstunt/debchange \
+ --force-distribution -v$v --distribution ${3:-unstable} "$1"
git add debian/changelog
debcommit
revision=$(( ${revision-0} + 1 ))
@@ -1058,7 +1059,7 @@ t-dch-commit-r () {
}
t-dch-commit () {
- faketime @"${GIT_AUTHOR_DATE% *}" dch "$@"
+ $troot/tstunt/debchange "$@"
git commit -m "dch $*" debian/changelog
}