summaryrefslogtreecommitdiff
path: root/tests/setup
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
commitcc704da52293859135140d783697360b55ea34a5 (patch)
tree7ca5bdb2177cb05a798d4ac8d292057a2c3abcf1 /tests/setup
parent29176533eff12cd3e90e3a3ce60e59ec1077b2ac (diff)
parent80660b109ae671e5164c6738919f34db06719236 (diff)
Merge tag 'debian/6.11' into stretch-bpo
dgit release 6.11 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sun 26 Aug 2018 01:58:34 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/setup')
-rwxr-xr-xtests/setup/gdr-convert-gbp36
1 files changed, 10 insertions, 26 deletions
diff --git a/tests/setup/gdr-convert-gbp b/tests/setup/gdr-convert-gbp
index a3baf2d..93ed4b6 100755
--- a/tests/setup/gdr-convert-gbp
+++ b/tests/setup/gdr-convert-gbp
@@ -15,28 +15,7 @@ not-gdr-processable () {
t-git-debrebase analyse | grep 'Unknown Unprocessable'
}
-p=example
-t-worktree 1.1
-
-cd example
-
-: 'fake up some kind of upstream'
-git checkout -b upstream quilt-tip
-rm -rf debian
-mkdir debian
-echo junk >debian/rules
-git add debian
-git commit -m "an upstream retcon ($0)"
-
-: 'fake up that our quilt-tip was descended from upstream'
-git checkout quilt-tip
-git merge --no-edit -s ours upstream
-
-: 'fake up that our quilt-tip had the patch queue in it'
-git checkout patch-queue/quilt-tip
-gbp pq export
-git add debian/patches
-git commit -m "patch queue update ($0)"
+t-gdr-gbp-import-core-with-queue
not-gdr-processable origin
@@ -44,10 +23,6 @@ not-gdr-processable origin
git branch make-upstream upstream
t-make-new-upstream-tarball 2.0
-: 'make branch names more conventional'
-git branch -D master
-git branch -m quilt-tip master
-
for b in \
quilt-tip-2 \
gitish-only \
@@ -67,6 +42,10 @@ not-gdr-processable merge
t-dch-commit -v 2.0-1 -m 'new upstream (did gbp import-orig)'
t-dch-commit-r
+echo garbage >debian/patches/garbage
+git add debian/patches/garbage
+git commit -m 'add garbage' debian/patches/garbage
+
$ifarchive t-archive-none $p
$ifarchive t-git-none
$ifarchive t-dgit -wgf --gbp push-source --new
@@ -84,8 +63,13 @@ git push --set-upstream origin master
t-expect-fail E:'identical in upstream files' \
t-git-debrebase -fupstream-has-debian convert-from-gbp upstream/2.0~
+t-expect-fail E:'Unused patch file garbage will be discarded' \
t-git-debrebase -fupstream-has-debian convert-from-gbp
+t-git-debrebase -fupstream-has-debian -funused-patches convert-from-gbp
+
+git branch converted-from-gbp
+
v=2.0-2
t-dch-commit -v $v -m 'switch to git-debrebase, no other changes'
t-dch-commit-r