summaryrefslogtreecommitdiff
path: root/tests/setup
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-02-15 19:08:44 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 12:25:49 +0100
commit4601685f60bcd8c1749cebb7237da80f025c338b (patch)
tree5265b0fb6de4d6f19864a57e5fc00d185c21fd0e /tests/setup
parent8900e2002df925ebdf4941d18094fc5ca408e027 (diff)
test suite: gbp2gdr: seems to work now
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/setup')
-rwxr-xr-xtests/setup/gbp2gdr27
1 files changed, 25 insertions, 2 deletions
diff --git a/tests/setup/gbp2gdr b/tests/setup/gbp2gdr
index 8088e98..5c2b969 100755
--- a/tests/setup/gbp2gdr
+++ b/tests/setup/gbp2gdr
@@ -7,7 +7,6 @@ t-dependencies git-buildpackage libfile-fnmatch-perl
t-tstunt-parsechangelog
-
not-gdr-processable () {
t-expect-fail F:'Cannot cope with this commit' \
t-git-debrebase
@@ -55,9 +54,33 @@ gbp import-orig --upstream-version=2.0 ../$ust
not-gdr-processable
+dch -v 2.0-1 -m 'new upstream (did gbp import-orig)'
+dch -r sid
+git commit -m changelog debian/changelog
+
+t-archive-none $p
+t-git-none
+t-dgit -wgf --gbp push-source --new
+
+t-salsa-add-remote
+git push --set-upstream origin master
+
+# OK now this looks like something more normal.
+# We have:
+# maintainer (gbp) view dgit view
+# master
+# debian/2.0-1 archive/debian/2.0-1
+# remotes/origin/master remotes/dgit/dgit/sid
+
t-git-debrebase -fupstream-has-debian gbp2debrebase
-: xxx
+dch -v 2.0-2 -m 'switch to git-debrebase, no other changes'
+dch -r sid
+git commit -m changelog debian/changelog
+
+t-dgit -wgf push-source --new --overwrite
+git push
+
t-ok
exit 0