summaryrefslogtreecommitdiff
path: root/tests/tests/gdr-fresh
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-09-03 21:28:39 -0700
commitcc704da52293859135140d783697360b55ea34a5 (patch)
tree7ca5bdb2177cb05a798d4ac8d292057a2c3abcf1 /tests/tests/gdr-fresh
parent29176533eff12cd3e90e3a3ce60e59ec1077b2ac (diff)
parent80660b109ae671e5164c6738919f34db06719236 (diff)
Merge tag 'debian/6.11' into stretch-bpo
dgit release 6.11 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sun 26 Aug 2018 01:58:34 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/tests/gdr-fresh')
-rwxr-xr-xtests/tests/gdr-fresh45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/tests/gdr-fresh b/tests/tests/gdr-fresh
new file mode 100755
index 0000000..169181c
--- /dev/null
+++ b/tests/tests/gdr-fresh
@@ -0,0 +1,45 @@
+#!/bin/bash
+set -e
+autoimport=
+. tests/lib
+. $troot/lib-gdr
+
+t-dependencies GDR
+
+t-gdr-gbp-import-core
+
+t-git-next-date
+
+# leaves us on upstream
+git rm debian/rules
+git commit -m 'strip upstream rules'
+git tag -f v1.0
+
+git branch -m master master.old
+git checkout -b master
+
+t-git-next-date
+
+git checkout quilt-tip debian
+git commit -m 'initial debianisation'
+
+t-make-orig example 1.0
+
+dgit-quilt-fixup-uses-gdr () {
+ t-git-next-date
+
+ DGIT_TEST_DEBUG=-DD t-dgit quilt-fixup 2>&1 |tee ../fixup.out
+ grep '^branch_is_gdr .* YES$' ../fixup.out
+}
+
+dgit-quilt-fixup-uses-gdr
+
+git checkout --detach patch-queue/quilt-tip
+git rebase master
+git push . HEAD:master
+git checkout master
+
+dgit-quilt-fixup-uses-gdr
+t-gdr-made-patches
+
+t-ok