summaryrefslogtreecommitdiff
path: root/tests/tests/import-quilt
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-08 20:21:35 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-08 23:05:47 +0100
commit3a434e0ecac4387bb900a078b7d65c751b99f3bb (patch)
tree2837251b9c43e42890c61651d009fcbb4dd75844 /tests/tests/import-quilt
parent305822addb2da1b3742cfabdfa71be50c39c48c1 (diff)
Test suite: import-nonnative: Enhanced and finished
Use t-git-next-date. (Our GIT_AUTHOR_DATE settings were wrong and therefore ineffective.) Add a 1.0 with diff test. Add some comments about package format. Now the test is finished. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/tests/import-quilt')
-rwxr-xr-xtests/tests/import-quilt74
1 files changed, 0 insertions, 74 deletions
diff --git a/tests/tests/import-quilt b/tests/tests/import-quilt
deleted file mode 100755
index 08ea866..0000000
--- a/tests/tests/import-quilt
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/bash
-set -e
-. tests/lib
-
-t-tstunt-parsechangelog
-
-chk () {
- p=$1
- v=$2
-
- t-archive $p $v
- t-git-none
- t-dgit --no-rm-on-error clone $p
-
- echo xxx do some basic checks
-
- # And now we make an update using the same orig tarball, and
- # check that the orig import is stable.
-
- cd $p
-
- git branch first-import
-
- m='Commit for import check'
- echo "$m" >>import-check
-
- v=${v%-*}-99
- dch -v $v -D unstable -m "$m"
-
- git add import-check debian/changelog
- git commit -m "$m"
-
- t-dgit -wgf quilt-fixup
- t-dgit -wgf build-source
-
- # The resulting .dsc does not have a Dgit line (because dgit push
- # puts that in). So we just shove it in the archive now
-
- ln ../${p}_${v}.* $tmp/mirror/pool/main/
- t-archive-query
-
- t-dgit fetch
-
- git branch first-2nd-import remotes/dgit/dgit/sid
-
- export GIT_AUTHOR_DATE=1475947851
- export GIT_COMMITTER_DATE=1475947851
-
- t-dgit fetch
-
- t-refs-same-start
- t-ref-same refs/remotes/dgit/dgit/sid
- t-ref-same refs/heads/first-2nd-import
-
- for orig in ../${p}_${v%-*}.orig*.tar.*; do
- orig=${orig#../}
- pat="^Import ${orig//./\\.}\$"
- t-refs-same-start
- for start in first-import first-2nd-import; do
- git log --pretty='tformat:%H' --grep "$pat" $start \
- >../t.imp
- test $(wc -l <../t.imp) = 1
- imp=$(cat ../t.imp)
- t-ref-same-val "$orig $start" "$imp"
- done
- done
- cd ..
-}
-
-chk example 1.0-1
-
-chk sunxi-tools 1.2-2.~~dgittest
-
-echo xxx need more.