summaryrefslogtreecommitdiff
path: root/tests/tests/push-source-with-changes
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-10-20 10:21:58 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-10-20 10:21:58 -0700
commit4ea49240ddaa77bb4e290f9018727805ef87efc6 (patch)
treeecc5ef8ce55fa7cce83ebc9554edeb29920ea2cf /tests/tests/push-source-with-changes
parentc1594eccda40a6a40bb2eb330a13578f330b3cc9 (diff)
parent16d99b2680f6c4e41c7740f542ca064455b4f5a4 (diff)
Merge tag 'debian/8.0' into stretch-bpo
dgit release 8.0 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sat 13 Oct 2018 04:01:49 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/tests/push-source-with-changes')
-rwxr-xr-xtests/tests/push-source-with-changes14
1 files changed, 12 insertions, 2 deletions
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 580ea3a..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -13,14 +13,24 @@ t-ref-head
# (1) try pushing a changes file containing binaries
-t-dgit --dpkg-buildpackage:-d build -F
+t-dgit build -F
t-expect-push-fail 'user-specified changes file is not source-only' \
t-dgit -C ../${p}_1.0_multi.changes push-source --new
# (2) try pushing a source-only changes file
-t-dgit --dpkg-buildpackage:-d build-source
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit build-source
+
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master