summaryrefslogtreecommitdiff
path: root/tests/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-09 12:40:03 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-10 01:01:11 +0100
commit93c85650b8fb5a656f01f44d947575bd71cb7d63 (patch)
tree5cbfc20a06c8294295547511c38795eaeb5f7017 /tests/tests
parentda2456e64add31d0ad28e2905b7a55e0ecb7000d (diff)
Test suite: Test that we pass correct -v to genchanges
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests/tests')
-rwxr-xr-xtests/tests/version-opt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/tests/version-opt b/tests/tests/version-opt
new file mode 100755
index 0000000..93c6a45
--- /dev/null
+++ b/tests/tests/version-opt
@@ -0,0 +1,32 @@
+#!/bin/bash
+set -e
+. tests/lib
+
+# NOT t-tstunt-parsechangelog
+# because that doesn't honour the perl option corresponding to -v
+
+t-debpolicy
+t-prep-newpackage example 1.0
+
+cd $p
+revision=1
+git tag start
+t-dgit setup-mergechangelogs
+
+t-dgit build-source
+t-dgit push --new
+
+t-archive-process-incoming sid
+
+for v in 1.1 1.2; do
+ dch -v $v -D unstable -m "Update to version $v"
+
+ git add debian/changelog
+ git commit -m "Commit changelog for $v"
+
+ t-dgit build-source
+done
+
+fgrep 'Update to version 1.1' ../${p}_${v}_source.changes
+
+echo ok.