summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-08-14 12:19:32 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-08-14 18:40:07 +0100
commitca007b4dde367c1316f4bfe36895dbea2fd34956 (patch)
tree8472fd41ecc18b8e10b093dbb065bdd13069f048 /tests
parentee802f8a6760c88b641f05d4dee51439a9a42c96 (diff)
Test suite: run-all: record output
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/run-all10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/run-all b/tests/run-all
index b5c5bb0..c6df386 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
set -e
# convenience script for running the tests outside adt-run
# usage: tests/using-intree tests/run-all
+set -o pipefail
+
set +e
jcpus=`perl -MSys::CPU -we 'printf "-j%d\n",Sys::CPU::cpu_count()'`
set -e
@@ -11,5 +13,7 @@ if [ $# != 0 ]; then
set TESTSCRIPTS="$*"
fi
-set -x
-exec make $jcpus -k -f tests/Makefile "$@"
+(
+ set -x
+ exec make $jcpus -k -f tests/Makefile "$@"
+) 2>&1 |tee tests/tmp/run-all.log