summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 12:37:11 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 13:08:41 +0100
commit470cf3f63b4d284dbaaef8da936e716438063ac1 (patch)
tree78ab5791488f19e3dfc7573941f81b7d24ff88e7 /tests
parent173757ec53902ea11825c26bb8245971c157455a (diff)
Test suite: rename list-tests to enumerate-tests for ease of completion over tests/lib*
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile2
-rwxr-xr-xtests/enumerate-tests (renamed from tests/list-tests)2
-rwxr-xr-xtests/tests/test-list-uptodate2
3 files changed, 3 insertions, 3 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 157b487..5bd3eee 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -1,7 +1,7 @@
# usage: tests/using-intree make -f tests/Makefile
# (optionally setting TESTSCRIPTS='tests/tests/foo tests/tests/bar')
-TESTSCRIPTS ?= $(shell tests/list-tests)
+TESTSCRIPTS ?= $(shell tests/enumerate-tests)
TESTNAMES := $(notdir $(TESTSCRIPTS))
all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
diff --git a/tests/list-tests b/tests/enumerate-tests
index 8578fe6..912ee4f 100755
--- a/tests/list-tests
+++ b/tests/enumerate-tests
@@ -88,7 +88,7 @@ seddery () {
local seddery=$1
sed <$t -n '
20q;
- /^: t-list-tests-end$/q;
+ /^: t-enumerate-tests-end$/q;
'"$seddery"'
'
}
diff --git a/tests/tests/test-list-uptodate b/tests/tests/test-list-uptodate
index a2b4c5b..65812ff 100755
--- a/tests/tests/test-list-uptodate
+++ b/tests/tests/test-list-uptodate
@@ -5,5 +5,5 @@ set -e
: "just verifies internal consistency of test suite"
cd $root
-$troot/list-tests gencontrol >$tmp/control-expected
+$troot/enumerate-tests gencontrol >$tmp/control-expected
diff debian/tests/control $tmp/control-expected