summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-25 15:46:55 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-25 15:46:56 +0000
commit224c9211c06b084eb9583708860ca1fff0e456ad (patch)
treea7cec8613b710855022bc764b57b6d217535adfe /tests
parent264ba387d05192ca4825eeddfeb7bbdab558ec8a (diff)
test suite: overwrite-chkclog: test UNRELEASED handling.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/tests/overwrite-chkclog11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/tests/overwrite-chkclog b/tests/tests/overwrite-chkclog
index 3544390..fee2181 100755
--- a/tests/tests/overwrite-chkclog
+++ b/tests/tests/overwrite-chkclog
@@ -23,6 +23,17 @@ git merge dgit/dgit/stable
git checkout master which
EDITOR=: git commit
+perl -i~ -pe 's/^(\w+ \(\S+\)) stable/$1 UNRELEASED/ if $.>1' debian/changelog
+git add debian/changelog
+git commit -m 'UNRELEASED changelog'
+
+t-dgit -wgf build
+
+t-expect-fail E:'Distribution.*is UNRELEASED' \
+t-dgit push --overwrite stable
+
+git revert --no-edit 'HEAD^{/UNRELEASED changelog}'
+
t-dgit -wgf build
perl -i~ -pe 's/^(\w+ \(\S+)(\) stable)/$1+X$2/ if $.>1' debian/changelog