summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 19:58:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-19 20:17:55 +0100
commit4323fe5c8a3904f55b18e516b6b02a8e3e0527e4 (patch)
tree618385a80087d8205223d8b1e9e9039129c3aaad /tests
parent02b9596d8061ff17a37a048521d0acdc34934c88 (diff)
test suite: gdr-convert-gbp: Break the start out into lib-gdr
This will allow us to test other things to do with this conversion without making tests/setup/gdr-convert-gbp more complicated. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests')
-rw-r--r--tests/lib-gdr30
-rwxr-xr-xtests/setup/gdr-convert-gbp27
2 files changed, 31 insertions, 26 deletions
diff --git a/tests/lib-gdr b/tests/lib-gdr
index 9d9fcb4..bda2679 100644
--- a/tests/lib-gdr
+++ b/tests/lib-gdr
@@ -329,3 +329,33 @@ t-gdr-prep-new-upstream () {
git checkout master
t-git-next-date
}
+
+t-gdr-gbp-import-core () {
+ p=example
+ t-worktree 1.1
+
+ cd example
+
+ : 'fake up some kind of upstream'
+ git checkout -b upstream quilt-tip
+ rm -rf debian
+ mkdir debian
+ echo junk >debian/rules
+ git add debian
+ git commit -m "an upstream retcon ($0)"
+ git tag v1.0
+
+ : 'fake up that our quilt-tip was descended from upstream'
+ git checkout quilt-tip
+ git merge --no-edit -s ours upstream
+
+ : 'fake up that our quilt-tip had the patch queue in it'
+ git checkout patch-queue/quilt-tip
+ gbp pq export
+ git add debian/patches
+ git commit -m "patch queue update ($0)"
+
+ : 'make branch names more conventional'
+ git branch -D master
+ git branch -m quilt-tip master
+}
diff --git a/tests/setup/gdr-convert-gbp b/tests/setup/gdr-convert-gbp
index b563c01..3b555e5 100755
--- a/tests/setup/gdr-convert-gbp
+++ b/tests/setup/gdr-convert-gbp
@@ -15,28 +15,7 @@ not-gdr-processable () {
t-git-debrebase analyse | grep 'Unknown Unprocessable'
}
-p=example
-t-worktree 1.1
-
-cd example
-
-: 'fake up some kind of upstream'
-git checkout -b upstream quilt-tip
-rm -rf debian
-mkdir debian
-echo junk >debian/rules
-git add debian
-git commit -m "an upstream retcon ($0)"
-
-: 'fake up that our quilt-tip was descended from upstream'
-git checkout quilt-tip
-git merge --no-edit -s ours upstream
-
-: 'fake up that our quilt-tip had the patch queue in it'
-git checkout patch-queue/quilt-tip
-gbp pq export
-git add debian/patches
-git commit -m "patch queue update ($0)"
+t-gdr-gbp-import-core
not-gdr-processable origin
@@ -44,10 +23,6 @@ not-gdr-processable origin
git branch make-upstream upstream
t-make-new-upstream-tarball 2.0
-: 'make branch names more conventional'
-git branch -D master
-git branch -m quilt-tip master
-
for b in \
quilt-tip-2 \
gitish-only \