summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-25 13:37:21 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-25 13:53:09 +0100
commitb765388a4cea92f5209e3fd9b59c05e88a278076 (patch)
tree25d27f19d2ed7ddffac33362b8ddbcc9cfb0a055 /tests
parent7bd28223f931fa3f36760e73c4e32673ca7f3cbe (diff)
test suite: Test dgit calling git-debrebase on new debianisation
Now all the cases in dgit's branch_is_gdr history walker are tested: DGIT_TEST_DEBUG=-DD tests/using-intree tests/run-all cat tests/tmp/*.log |perl -ne 'next unless s/^branch_is_gdr \w+ //; print' |sort -u |less Produces the same list as: git-grep 'branch_is_gdr ' | perl -pe 's/^^dgit:\s+//' |sort |less (With the list of gdr commit annotations the same as in the source.) Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/tests/gdr-fresh45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/tests/gdr-fresh b/tests/tests/gdr-fresh
new file mode 100755
index 0000000..b1e7390
--- /dev/null
+++ b/tests/tests/gdr-fresh
@@ -0,0 +1,45 @@
+#!/bin/bash
+set -e
+autoimport=
+. tests/lib
+. $troot/lib-gdr
+
+t-dependencies NO-DGIT devscripts GDR
+
+t-gdr-gbp-import-core
+
+t-git-next-date
+
+# leaves us on upstream
+git rm debian/rules
+git commit -m 'strip upstream rules'
+git tag -f v1.0
+
+git branch -m master master.old
+git checkout -b master
+
+t-git-next-date
+
+git checkout quilt-tip debian
+git commit -m 'initial debianisation'
+
+git-deborig
+
+dgit-quilt-fixup-uses-gdr () {
+ t-git-next-date
+
+ DGIT_TEST_DEBUG=-DD t-dgit quilt-fixup 2>&1 |tee ../fixup.out
+ grep '^branch_is_gdr .* YES$' ../fixup.out
+}
+
+dgit-quilt-fixup-uses-gdr
+
+git checkout --detach patch-queue/quilt-tip
+git rebase master
+git push . HEAD:master
+git checkout master
+
+dgit-quilt-fixup-uses-gdr
+t-gdr-made-patches
+
+t-ok